俄罗斯贵宾会-俄罗斯贵宾会官网
做最好的网站

Scrapy安装错误:Microsoft Visual C++ 14.0 is required...

第二步: 执行pip install D:/download/Twisted‑18.7.0‑cp36‑cp36m‑win_amd64.whl  即可完成whl文件的安装

error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools": http://landinghub.visualstudio.com/visual-cpp-build-tools

    cp后面表示python的版本号, 32/64表示操作系统.

其中install后面为下载的whl文件的完整路径名

  1. 接下来就是安装了:

在windows下,在dos中运行pip install Scrapy报错:

Invalid requirement: 'D:downloadTwisted-18.7.0-cp36-cp36m-win_amd64'
It looks like a path. File 'D:downloadTwisted-18.7.0-cp36-cp36m-win_amd64' does not exist.

1

环境是 Win8 64位 Python3.6

当前环境win10,python_3.6.1,64位。

第三步: 安装Scrapy,执行命令:pip install Scrapy

俄罗斯贵宾会,1

 

pipinstallScrapy

使用pip安装Python Scrapy时出现以下错误:

pip install C:UsersCRDownloadsTwisted-17.5.0-cp36-cp36m-win_amd64.whl

详细步骤:

building 'twisted.test.raiser' extension

参考资料:http://blog.csdn.net/vola9527/article/details/44338181

问题描述

  1. 下载对应的whl文件:https://www.lfd.uci.edu/~gohlke/pythonlibs/#twisted 

安装完成后,再次运行:

  • Twisted‑18.7.0‑cp27‑cp27m‑win32.whl
  • Twisted‑18.7.0‑cp27‑cp27m‑win_amd64.whl
  • Twisted‑18.7.0‑cp34‑cp34m‑win32.whl
  • Twisted‑18.7.0‑cp34‑cp34m‑win_amd64.whl
  • Twisted‑18.7.0‑cp35‑cp35m‑win32.whl
  • Twisted‑18.7.0‑cp35‑cp35m‑win_amd64.whl
  • Twisted‑18.7.0‑cp36‑cp36m‑win32.whl
  • Twisted‑18.7.0‑cp36‑cp36m‑win_amd64.whl
  • Twisted‑18.7.0‑cp37‑cp37m‑win32.whl
  • Twisted‑18.7.0‑cp37‑cp37m‑win_amd64.whl

http://www.lfd.uci.edu/~gohlke/pythonlibs/#twisted下载twisted对应版本的whl文件(如我的Twisted‑17.5.0‑cp36‑cp36m‑win_amd64.whl),cp后面是python版本,amd64代表64位,运行命令:

本文由俄罗斯贵宾会发布于编程,转载请注明出处: Scrapy安装错误:Microsoft Visual C++ 14.0 is required...

您可能还会对下面的文章感兴趣: