俄罗斯贵宾会-俄罗斯贵宾会官网
做最好的网站

俄罗斯贵宾会Windows下安装lxml库方法

如果直接用pip install lxml安装成功,那么恭喜!!!

在windows下安装Scrapy的错误挺多的, 我将我安装成功的步骤发出来,供更多的人参考。

一般在windows安装都十分蛋疼,pip无法直接安装(提示错误一大片,此处省略……)


因此选择wheel安装方式,步骤如下:

eg:直接通过pip来安装,在windows下打开cmd窗口,输入

pip install Scrapy

有可能会安装不成功。

1、打开cmd,安装wheel库文件:


pip install wheel

测试环境:win7 64位旗舰版+python 3.6

 

首先,直接进入Scrapy网站的文档Installation guide下的 Installing Scrapy下:

2、查看python对应的版本:

https://doc.scrapy.org/en/1.2/intro/install.html

控制台或者启动python IDLE后,输入:

俄罗斯贵宾会 1

import pip

图片中绿色字为安装Scrapy所依赖的包,要全部安装这些依赖包

print(pip.pep425tags.get_俄罗斯贵宾会,supported())

parsel, w3lib, pyOpenSSL,cryptography这些可以直接使用pip命令安装,注意安装的顺序。

(注意:上面的print()是python3的写法,如果python2输入上述代码有误,去掉print后面的括号。)

pip install parsel

打印出来的结果类似下图:

而lxml和twisted使用pip安装则会出现错误。

 俄罗斯贵宾会 2

这两个包可以在如下网站下载whl文件,之后在安装。

从(‘cp34’, ‘none’, ‘win32’)可以看出当前使用的是3.4系版本,win32位,故登录到pypi.python.org搜索下载对应版本的lxml wheel文件:

http://www.lfd.uci.edu/~gohlke/pythonlibs/

lxml-4.2.4-cp34-cp34m-win32.whl

注意下载时要选择自己操作系统位数和python软件位数对应的进行下载

 

俄罗斯贵宾会 3

3、从控制台安装whl文件:

cp后面跟的数字是python的版本,比如现在我的python版本是3.6,那么需要下载cp36;

pip install lxml-4.2.4-cp34-cp34m-win32.whl

把下载的.whl文件放在一个容易寻找的地址(我放在了D:)

 

然后在控制台进入该地址

网上的大部分教程执行到这一步就没了,我在实际安装中,执行此命令提示错误,并不能安装:

在该地址下输入

俄罗斯贵宾会 4

pip  install  xxxx.whl

pip.log文档中错误提示信息又是一大片……

注:[whl]表示你的.whl文件,一定要全名,XXXX.whl

本文由俄罗斯贵宾会发布于编程,转载请注明出处:俄罗斯贵宾会Windows下安装lxml库方法

您可能还会对下面的文章感兴趣: